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1. System Overview 

The CaseCracker Interview Management System is intended for the recording of law 
enforcement interviews.  It typically consists of an interview room, containing a covert 
microphone, one or two covert cameras, and a switch for marking points of interest (optional).  
Elsewhere in the building, an interview monitoring station contains a DVD recorder (optional), 
and the CaseCracker workstation:  

 

The operational mode of the system is that during an interview, two recordings of the video and 
audio are made: 

 The DVD recorder creates a master evidentiary copy on a regular DVD.  Typically, at 
the end of the interview, this DVD can be checked into evidence. 

 The CaseCracker workstation creates a working copy of the video and audio, on the 
computer’s hard drive.  This copy can be easily searched and annotated.  
Additionally, it is possible to burn a DVD from the working copy. 

The remainder of this document details the operation of the system from the perspective of an 
administrator of the system.  User tasks are covered in a separate document.  If you have not read 
it already, please familiarize yourself with the User Manual first. 

2. Users  

a. The general mode of operation of the CaseCracker system is that each user, even an 
administrator, should log on to his or her own account.  This preserves the integrity 
of event logs, since actions on the system are logged with the name of the currently-
logged-in user.  Any individual account can be marked as having administration 
privileges. 
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Note: Unless otherwise noted, the tasks outlined in this manual require you to be 
logged in to the system with administrator privileges. 

b. Special Accounts: In addition to individual user accounts, there are two special 
accounts that cannot be deleted.   

The ‘Administrator’ is the top-level (or master) administration account.  By default, 
the password for the Administrator user is ‘welcome’, though this can be changed by 
logging in as Administrator and selecting Tools > Set Password from the menu bar. 

There is also a ‘root’ user.  Logging in as this user provides privileged access to the 
underlying Linux operating system, and should be used only under the instruction of a 
Cardinal Peak support engineer.  The password for the ‘root’ user is always the same 
as the password for the ‘Administrator’ user. 

Important: You should change the password of the ‘Administrator’ user immediately! 

c. To add, modify, and delete user accounts: Select Tools > Manage Users from the 
main menu.  The following dialog will appear, showing all the currently-configured 
individual user accounts: 

 

 

 

To add a new user: Click the ‘Add New…’ button.  The following dialog box 
appears: 
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The Full Name of the user is typically their first and last names, potentially including 
their rank. 

The Sort By field is used for sorting this user’s name appropriately in lists.  It is 
typically their last name.  As you enter the user’s Full Name, the system will attempt 
to guess the appropriate value for the Sort By field, but you may need to correct it. 

The Password and Confirm Password fields allow you to set the user’s initial 
password.  The default password is ‘welcome’. 

If the ‘Force user to change password on next login’ box is checked, the user will be 
required to change their password the next time they log in. 

If the ‘Grant this user administrator privileges’ box is checked, the user will have 
administrator level access to the system.  (We recommend you limit the number of 
people who have this permission, as it is possible for a user with administration 
privileges to inadvertently misconfigure important system parameters.) 

d. To edit an existing user: Select the user’s name from the Edit User List dialog and 
click the ‘Edit…’ button. See the description under adding a new user for an 
explanation of this dialog box. 

e. To delete an existing user: Select the user’s name from the Edit User List dialog and 
click the ‘Delete…’ button.  You will be prompted to confirm your action. Note: 
deleting a user will not delete video associated with that user. 
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3. Setup  

To enter setup, select Tools > Setup and the following dialog will appear: 

 

a. Names: Select the Names tab to enter the name of the department and the names 
of up to two recording inputs. You may also customize the Incident Name field 
to be more specific to your agency, for example, Case Number.  

b. Recording: Select the Recording tab to configure recording parameters: 

 

The video quality setting controls the tradeoff between high video quality, on the 
one hand, and longer recording capacity, on the other.   

Good quality is designed to be sufficient for most applications.  It is roughly 
equivalent to VCR quality.   
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Better quality offers higher video resolution and clarity.  It is better than VCR 
quality, but not quite as good as movie-level DVD quality.   

Best quality setting provides the highest resolution available, however, it places 
demand on the system’s CPU and results in large on-disk files. (This setting is not 
recommended for 2-room systems on GX520 hardware.)  

Picture-in-Picture allows two cameras in each interview room, picture-in-picture 
(PIP) is enabled and the setup is in this screen. For each room you can choose 
whether or not to have PIP on or off and where the small box appears on the 
screen. 

If the ‘Allow users to pause during recording’ box is checked, users will be 
permitted to pause recording. 

If the ‘Prompt user to start/stop external DVD recorder’ box is checked, the user 
will be prompted to start the external DVD recorder at the start of each session. 

If the ‘Allow users to swap the main and PIP images’ box is checked, users will 
be able to swap the main camera view with the PIP camera view during recording. 

c. Permissions: Select the Permissions tab to configure permissions:  

 

This dialog allows you to specify the permissions that an Interviewer has for his 
or her own sessions, and also allows you to specify the permissions that other 
people have for sessions they did not record.  The meaning of columns is as 
follows: 

 The View / Search permission allows a user to play back a session, and 
also to search it.  If a user can play a session, they also have the ability to 
burn a DVD or burn the audio to CD.  

 The Annotate permission allows a user to add, edit, and delete annotations 
and flags during playback.  It is always possible to add annotations and 
flags during recording, regardless of the setting in this dialog. 
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 The Export permission allows a user to burn a DVD, or to export an audio 
file a video file, a snapshot, or the list of annotations. (It is always possible 
for users to export session information – though not the session’s contents 
– from the main window, regardless of the setting in this dialog.) 

 The Delete permission allows a user to immediately delete a session, to 
change its deletion date, and to prevent it from being automatically 
deleted. 

 If the “Enable streaming of live interviews over the network” box is 
checked, any user can remotely view any live recordings. To begin a 
remote viewing session on a PC, browse to the IP address (found at the 
bottom right of the main screen, see image below) of the CaseCracker 
recording the session.  

Note: Remote viewing is supported on Windows XP, Windows Vista, and 
Windows 7 running either Internet Explorer 8 or Internet Explorer 9. 

 

Note: administrators always have permission to perform all actions on the system. 

d. Controlling Deletion: Select the Automatic Deletion tab to configure deletion 
settings: 

 

The CaseCracker system allows you to set a policy regarding how long interviews 
are retained on the system by default.  (You can override the default policy on a 
session-by-session basis.)  Although it is possible to turn off automatic deletion, 
we recommend you set a department policy and stick with it.  Aside from 
potential legal issues, a policy of automatically deleting old sessions makes it less 
likely you will run out of disk space. 
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If the ‘Delete sessions automatically’ box is checked, then the system will 
automatically delete video the specified number of days after it was recorded.  

 To override the automatic deletion for any particular session:  Select the 
session in the main window, and then select Session > Change Deletion Date 
from the main menu.  The following dialog box appears: 

 

From this dialog, you can select a new date and time for the session to be 
automatically deleted.  You can also keep it until it is manually deleted, by 
turning off the ‘Delete this session automatically’ checkbox. 

 To delete a session immediately:  Select the session in the main window and 
then select Session > Delete Now from the menu. 

e. Exporting: CaseCracker allows exporting of video, audio, image snapshots, 
annotations, event log, and session report to a variety of different destinations. In 
order for this functionality to work, you will need to connect CaseCracker to 
your network and configure the following destination(s) per your department’s 
policy.  

Regardless of the settings on this tab, Users who are not administrators will only 
be able to export video, audio, image snapshots, and annotations if they have 
“Export” permission for the session in question; see the “Permissions” tab, 
above. 
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Allow export via email: If you would like to enable email, check the “Allow 
export via email” box and click the “Configure” button to the right to view the 
window below. Enter in your department’s outgoing mail server, authentication 
(if necessary), and a “from” email address. Click the test button to send a test 
email to confirm settings. Note: Video file sizes are limited using this export 
option. 

 

Allow export to files: If you would like to enable export to the filesystem (which 
could be a location on your Department’s network if this CaseCracker 
workstation is configured as a network client), check the “Allow export to files” 
box and click the “Configure” button to the right to view the window below. Use 
the browse button to choose the default folder that files will be exported to. 
Checking the “Allow users to browse to other folders” box will allow users to 
change to other folders within the filesystem.   
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Allow export to USB devices: If you would like to enable export to USB devices, 
check the “Allow export to USB devices” box. 

Allow export to FTP servers: If you would like to enable export to a FTP server, 
check the “Allow export to FTP servers” box and click the “Configure” button to 
the right to view the window below.  

 

Allow export to DIMS: If your department uses Linear Systems’ Digital 
Information Management System, check the “Allow export to DIMS” box and 
click the “Configure” button.  

 

f. Auto Export: Enabling this feature will allow CaseCracker to automatically export a 
session to DIMS or as an MP4 to a file location immediately after the session has 
finished recording.  
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4. Disk Usage 

a. Your system has been configured with internal hard disk(s) for video and audio 
storage.  (This is in addition to the system’s root hard disk, which stores the operating 
system and other software, as well as numerous configuration files.)  It is possible to 
add external storage to the system by purchasing one or more Network-Attached 
Storage (NAS) devices. 

Note: Due to security considerations and the high data access rates that are required 
for proper operation, Cardinal Peak only certifies the system for use with certain 
approved NAS devices.  Please contact Cardinal Peak for details. 

b. To see a list of the configured disks and NAS units: Select Tools > Manage Disk 
Storage from the main menu.  The following dialog box appears: 
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The first entry in the list, usually ‘/data1’, refers to the CaseCracker workstation’s 
internal data disk.   

Any NAS units you have configured will also appear in this list. 

c. To ascertain a particular session’s size and storage location: Select the session from 
the main window, and the select Session > Info from the menu.  The size and storage 
location are listed in the bottom of the info window. 

d. To add a NAS to the system: First, add the NAS unit to the network.  (Contact 
Cardinal Peak support for instructions on how to do this.)   

e. To delete a NAS from the system: Select the NAS from the list, and click the 
‘Delete…’ button.  You will be prompted to confirm your action.   

Important: When you delete a NAS from the system, you are also deleting all the 
video stored on that NAS! 

5. Backing Up and Restoring Sessions 

a. Backup: To conserve storage on the hard disk, you can backup a session that can be 
loaded back to CaseCracker later. You may backup to DVD, file location, or USB 
device. Select one or more sessions and go to File > Backup session to view the 
window below. Select the destination and click OK. This will give you an archival 
copy of the interview with annotations and flags that can be restored to CaseCracker 
later.  

Note: This file can only be read by CaseCracker software.   
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b. Restoring from a DVD backup: 

1. Insert the DVD backup of the session that you would like to restore into the CD-
ROM drive on the CaseCracker unit. 

2. Log into CaseCracker as an Administrator or a user with administrative 
privileges. 

3. From the “CaseCracker Main Window”, escape to the shell by selecting Help 
followed by selecting Escape to Shell (advanced). 

4. Type the following into the shell window: 

sudo mount –t udf /dev/cdrom /media/cdrom 

Press Enter. 

5. Enter your password and press Enter. 

6. If you are restoring from a backup created with an earlier version than 
CaseCracker 3.0 than do the following. Otherwise, skip to step 7. 

Type the following into the shell window: 

mkdir /tmp/backup-restore 

Press Enter.  

cd /tmp/backup-restore 

Press Enter. 

tar xf /media/cdrom/session-XXX.nut 

NOTE: Substitute “XXX” with the session ID in the command above. 

7. Return to the “CaseCracker Main Window” and select File followed by selecting 
Restore from Backup. 

8. In the “Please locate the sessioninfo file…” window, double-click on media in 
the “Folders” column followed by double-clicking cdrom also in the “Folders” 
column. 

NOTE: If you followed step 6 you will double-click tmp in the “Folders” column 
followed by double-clicking backup-restore also in the “Folders” column. 

9. In the “Files” column, select sessioninfo and select OK. 

The restore process will start. Depending on the size of the session it may take 
several minutes to restore. 
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10. Once the session has completed restoring, click OK. 

11. Return to the Shell window that was previously opened and type the following: 

sudo umount /media/cdrom 

Press Enter. 

12. Close the shell window. 

13. Eject the backup DVD from the CD-ROM drive. 

c. Restoring from a USB backup: 

1. Plug in the USB drive containing the session that you would like to restore to the 
CaseCracker unit. 

2. Log into CaseCracker as an Administrator or a user with administrative 
privileges. 

3. From the “CaseCracker Main Window,” go to File > Restore from Backup. 

4. Double-click on media/ 

5. Double-click on the USB drive. 

6. Double-click on the session you would like to restore. 

7. Double-click on the file sessioninfo. 

8. After the session restores, you must first unmount the USB drive. To do so, select 
the Help menu from the “CaseCracker Main Window,” followed by selecting 
Escape to Shell (advanced). 

9. Type the following into the shell window: 

umount /media/XXX 

NOTE: Substitute “XXX” with the name of the USB drive in the command   
above. 

10. Remove the USB drive from the CaseCracker. 

6. Validating Watermarks 

a. In order to verify that the audio and video associated with a session have not been 
modified since recording, highlight a session and select Session > Validate 
Watermarks. 
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7. Setting the Time and Date 

a. In order for time and date stamps to work correctly, it is important that the system has 
an accurate idea of the current time.  There are two ways to configure time:  
 Using the static method, you simply set the system clock to the correct time and 

date; from there, the system will keep reasonably accurate time, including making 
adjustments for daylight savings time as needed.   

 Using the dynamic method, your system can be configured to periodically 
synchronize to the current time over the Internet, using a publicly available 
timeserver. 

b. To configure the time and date, select Tools > Set Time/Date from the main menu.  
The following dialog will appear: 

 

c. To configure the current date and time statically, simply enter the values here and 
then move on to button, ‘Time Zone’.  To configure the system to dynamically 
synchronize over the network with a public server, choose “Keep synchronized with 
internet servers” from the Configuration drop down menu. The following window 
will appear prompting you to choose a time server. 
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8. Viewing the Event Log 

a. The following actions are logged to the system event log:
 Add (record) a session 
 View a session 
 Change a session’s 

expiration date 
 Delete session 
 Add user 
 Edit user 
 Delete user 

 Add filesystem 
 Delete filesystem 
 Burn DVD 
 Change permissions 
 Log in 
 Log out 
 Escape to shell 

b. To access the system event log: Select File > View Event Log from the main menu.  
The Event Log viewer appears: 

 

Events are sorted in chronological order.   

c. To get more details on any event: Select it and double-click on it. 

d. To export the Event Log: Select File > Export Event Log from the Event Log menu.  
The event log can be opened with Microsoft Excel. 

e. To close the Event Log: Select File > Close from the Event Log menu, or click the 
‘X’ in the upper right corner of the window.  
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Appendix: Support Tools 

In the event your system needs technical support, there are three options available from the Help 
menu when you’re logged in with administrator privileges that aid Cardinal Peak in remotely 
debugging your system. 

Although you should never need to access these options unless instructed to do so by Cardinal 
Peak, the functionality is as follows: 

 Install New Version allows you to install CaseCracker upgrades from an upgrade CD 
(software support contract required). 

 Escape to Shell allows you to access a Linux command prompt.  It is intended for 
expert users only, as it is possible to inadvertently mis-configure your system. 

 Burn Diagnostic CD allows you to burn a CD that contains a reasonably complete 
snapshot of the state of your system.  You can then send this CD or email the file to 
Cardinal Peak for analysis. 

 Allow Remote Login allows Cardinal Peak to login to your CaseCracker for 
diagnostic purposes. Your system must be connected to the network to allow remote 
login. 

 Play Test Sound is used to test audio configuration. 
 USB Contact Closure Test checks whether or not any USB devices are connected and 

working properly. 
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Appendix: Initial Configuration Checklist 

The following checklist provides a handy reference to ensure that you’ve performed initial 
system configuration correctly: 

____ Change Administrator password 

____ Add users to the system 

____ Configure default permissions 

____ Configure automatic deletion policy 

____ Configure recording parameters 

____ Set the time and date 

____ Configure export options 

 

  

 

 


